Breaking News

How to solve jvm is not suitable for this product. version 1.8 greater is required for eclipse

Are you facing below issue when you are trying open eclipse?

“Version 1.6 of the jvm is not suitable for this product. version 1.8 greater is required for eclipse neon in window”

 

First  need to download Jdk1.8 or if you have already then, need to find out where is your Java home directory. Normally it will be on C:\Program Files

The reason is that we don’t specify the environment variable

To solve this problem we just need add environment variables in “System Variables”

To find the  system variable: control panel  > System –> Advanced System Setting  –> Environment variables

Add the following variables by adding “NEW” :

  • Variable name :   JAVA_HOME
  • Variable valueC:\Program Files (x86)\Java\jdk1.8.0_91       (The path you installed the jdk)
  • Variable name:  CLASSPATH
  • Variable value:   .;%JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar;         //don’t forget the “.”
  • Variable namePath
  • Variable value%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin;

This above steps will solve this problem.

Leave a Reply

Your email address will not be published. Required fields are marked *

*